[/LoovtO.net]

Accueil > Informatique > Logiciels > Internet > TeamSpeak : Erreur "No reply from server"

TeamSpeak : Erreur "No reply from server"

mercredi 18 février 2009, par Sebastien Le Lourec

Lorsque que quelqu’un tente de se connecter à votre serveur TeamSpeak, il obtient le message d’erreur

No reply from server
Maybe the server is offline
or maybe teamspeak is not running on it


Les éventuelles commandes que je donnerai ici ne sont valables que pour Debian GNU/Linux. Pour les autres distribs demandez toujours... Pour Windows... passez à Linux !

Premier cas : L’utilisateur obtient ce message pour tous les serveurs.
Le problème doit être de son côté. Qu’il commence par regarder ses règles de pare-feu par exemple.

Second cas : L’utilisateur arrive à se connecter à d’autre serveurs mais obtient ce message quand il tente de se connecter au votre.
Dans ce cas, plusieurs vérifications s’imposent.

1. Vérifiez que le service teamspeak est bien lancé sur votre serveur.
Si ça n’est pas le cas démarrez le :
/etc/init.d/teamspeak-server start

2. Tentez une connexion à l’interface d’administration.
- Si cela ne fonctionne pas, dans le cas où vous hébergez d’autres sites web sur ce serveur vérifiez qu’ils fonctionnent. Si ça n’est pas le cas, il s’agit peut-être d’un problème réseau ou pare-feu. Cherchez à faire fonctionner votre serveur web afin d’accéder à l’interface d’administration avant d’aller plus loin.
- Si la connexion à l’interface d’administration fonctionne, vérifiez que le serveur TS est bien lancé.

3. Si le serveur TS est bien lancé.
Il peut s’agir d’un "petit problème" de config. Il arrive dans certains cas (sur les serveurs privés virtuels ou RPS en particulier) que la com entre l’adresse IP failover et l’adresse IP réelle se fasse moyennement. Pour résoudre ce soucis commencez par taper la commande suivante :
# ifconfig
Pour chacune des lignes eth0 et eth0:0 notez les adresses que vous trouverez derrière inet adr:.
Ensuite éditez le fichier server.ini qui doit se trouver dans /etc/teamspeak-server/. Les premières lignes devraient contenir :

[Main Config]
BoundToIp1=
ExternalIPDectection=1
HTTPServer Port=14534
HTTPServer Enabled=1
DateTimeFormat=dd-mm-yyyy hh:nn:ss
TCPQueryPort=51234
AllowedClientNameChars=
DisAllowedClientNameChars=()[]{}

Commencez par faire un essai avec l’adresse trouvée pour eth0. Saisissez la après BoundToIp1= puis redémarrez le serveur TS avec la commande :
/etc/init.d/teamspeak-server restart
Si après cette relance, les clients n’arrivent toujours pas à se connecter, essayez la même manipulation avec l’adresse trouvée pour eth0:0.

Certaines des informations de résolution de ce problèmes ont été tirées de différents posts du Forum OVH.

Coffee time !

Messages

Un message, un commentaire ?

Qui êtes-vous ?
Votre message

Pour créer des paragraphes, laissez simplement des lignes vides.